Zakłócenia 10Hz

Wszelkie sprawy związane z LabVIEW i komunikacją ze sprzętem. Problemy i ciekawe rozwiązania.
mwojcie3
Posty: 23
Rejestracja: 07 sty 2015 07:05
Wersja środowiska: LabVIEW 2013

Zakłócenia 10Hz

Post autor: mwojcie3 » 22 sty 2018 10:28

Witam

Jestem w trakcie realizacji jak dla mnie dość złożonego projektu. Podczas pomiarów pojawiając się zakłócenia o częstotliwości 10 Hz, za cholerę nie mogę dojść skąd się mogą one pojawiać. Przewód pomiarowy jest nie ekranowany, więc łapie pewnie wszystko :(.

W załączniku zrzut ekranu ze zmierzonych sygnałów.
Załączniki
zaklocenia.jpg

spalinowy
Posty: 101
Rejestracja: 03 lut 2012 15:09
Wersja środowiska: LabVIEW 2017
Lokalizacja: Warszawa
Been thanked: 3 times
Kontakt:

Re: Zakłócenia 10Hz

Post autor: spalinowy » 22 sty 2018 18:38

No niestety, ale z zakłóceniami musisz sobie poradzić sam. Ani nie wiem nic o aparaturze jakiej używasz, ani o otoczeniu pomiarowym, które może generować zakłócenia. Na tym etapie to wróżenie z fusów.

Awatar użytkownika
jogurt_owocowy
Posty: 1316
Rejestracja: 30 lis 2004 00:00
Wersja środowiska: LabVIEW 2015
Lokalizacja: Kraków
Been thanked: 1 time
Kontakt:

Re: Zakłócenia 10Hz

Post autor: jogurt_owocowy » 22 sty 2018 20:41

Podczas pomiarów pojawiając się zakłócenia o częstotliwości 10 Hz, za cholerę nie mogę dojść skąd się mogą one pojawiać.
Dawno temu był na forum podobny temat: Spektrum mocy - problemy.

PiDi
Posty: 616
Rejestracja: 31 gru 2010 01:36
Wersja środowiska: LabVIEW 2017
Lokalizacja: Katowice
Has thanked: 3 times
Been thanked: 3 times

Re: Zakłócenia 10Hz

Post autor: PiDi » 22 sty 2018 22:59

To może być jakiś błąd programowy, typu inicjalizowanie jakiegoś filtru zamiast ciągłej filtracji. Ale równie dobrze coś może faktycznie siać po przewodach. Pokaż kod, przede wszystkim ten, który odpowiada za pomiar.
ObrazekObrazekObrazekObrazek

mwojcie3
Posty: 23
Rejestracja: 07 sty 2015 07:05
Wersja środowiska: LabVIEW 2013

Re: Zakłócenia 10Hz

Post autor: mwojcie3 » 07 lut 2018 13:43

Kod całego programu w załączniku.
Jest dość skomplikowany, więc wszystkie pliki zapuszczam. Pętla pomiarowa w folderze Loops/Acquisition Message Loop.
Dzięki za pomoc.
Załączniki
Stoisko.rar
(1.4 MiB) Pobrany 65 razy

mwojcie3
Posty: 23
Rejestracja: 07 sty 2015 07:05
Wersja środowiska: LabVIEW 2013

Re: Zakłócenia 10Hz

Post autor: mwojcie3 » 07 lut 2018 13:50

Zaekranowałem przewody. Niestety raz są szpilki a raz ich nie ma. Jest to zjawisko strasznie nie powtarzalne.
1.jpg
2.jpg

ODPOWIEDZ